Moderate Activity

News

  Analyzed 5 days ago based on code collected 5 days ago.
 
Posted 2 months ago by Josep Maria Antolín Segura
The next beta version of Psycle is ready. Psycle 1.11.2 can be found in the Files section.

This new release contains bugfixes for several problems that existed in the first beta. Notoriously, several crashes and hangs, but also smaller ... [More] ones.

Development is now focused in improving some corner cases of Sampulse and Lua, and update the help file. [Less]
Posted 3 months ago by Josep Maria Antolín Segura
The first beta version for the upcoming 1.12 is ready. You can download version 1.11.1 from Sourceforge.

This release contains two major additions: A new Plugin Host which allows to make plugins with Lua scripting, and the first really ... [More] usable version of the Sampulse Machine.
As for the first one, there are four example plugins included in the LuaScripts dir, as well as an API documentation which includes a small tutorial. Find it in the docs folder.

This version also incorporates new Artwork, from the installer, to the icon, to the skin and colours. The older skin is included in the Skins folder in case you prefer the older look. [Less]
Posted over 1 year ago by Josep Maria Antolín Segura
The changes to the song loading mechanism caused songs made with the previous release to not load correctly. (Just happened with that one version).
I have fixed it for the vc2005 compile. The vc2003 compile will need to wait until the weekend to be able to upload it again.
Posted over 1 year ago by Josep Maria Antolín Segura
The changes to the song loading mechanism caused songs made with the previous release to not load correctly. (Just happened with that one version).
I have fixed it for the vc2005 compile. The vc2003 compile will need to wait until the weekend to be able to upload it again.
Posted over 1 year ago by Josep Maria Antolín Segura
This release contains mostly the fixes for the song loading (several 1.8 and 1.7 .psy files could fail to load), as well as fixes on the native plugins, happening only in the vc2005 compile.
Now it should be considered safe to use.
Posted over 1 year ago by Josep Maria Antolín Segura
This release contains mostly the fixes for the song loading (several 1.8 and 1.7 .psy files could fail to load), as well as fixes on the native plugins, happening only in the vc2005 compile.
Now it should be considered safe to use.
Posted over 1 year ago by Josep Maria Antolín Segura
A new maintenance version for Psycle has been released. Psycle 1.8.6.

This version is based on Psycle 1.8.5 and contains several fixes done during the year 2008, plus a couple of selected changes of 2009.

The main program is packed ... [More] into three different installers. One for old SSE processors, another for SSE2 capable processors, and a third one for SSE2 capable processors, but compiled with visual studio 2005.

Note: vc2005 version contains updated plugins. The others contain the same versions as 1.8.5.

Note 2: Newer version will be compiled with vc 2005 or maybe 2008, so if the vc2005 compile doesn't work for you, tell us. [Less]
Posted over 1 year ago by Josep Maria Antolín Segura
A new maintenance version for Psycle has been released. Psycle 1.8.6.

This version is based on Psycle 1.8.5 and contains several fixes done during the year 2008, plus a couple of selected changes of 2009.

The main program is packed ... [More] into three different installers. One for old SSE processors, another for SSE2 capable processors, and a third one for SSE2 capable processors, but compiled with visual studio 2005.

Note: vc2005 version contains updated plugins. The others contain the same versions as 1.8.5.

Note 2: Newer version will be compiled with vc 2005 or maybe 2008, so if the vc2005 compile doesn't work for you, tell us. [Less]
Posted over 1 year ago by Josep Maria Antolín Segura
Psycle 1.8.5 stable has been released today.

It is distributed in both, .zip and .exe (Installer) package types, and there is one for SSE CPU's and another for SSE2 CPU's. ( If your cpu has less than 4 years, you most probably can use the ... [More] SSE2 version).

Note that there's a fifth download available: A VST plugin pack. You don't need to manually download it if you use the installer. If you get the .zip, then get it to have a good selection of plugins (some of them needed for the demo songs). [Less]
Posted over 1 year ago by Josep Maria Antolín Segura
Psycle is a Music tracker (like FastTracker 2 or Impulse Tracker) combined with plugin modularity. It supports its own plugin API, the VST2 plugin standard, and a tracker style sampler playback.

The winamp plugin has been updated with the ... [More] source code from Psycle 1.8.5 so it is now fully compatible with the current version.

The dialogs have been improved partially aswell.

It is available to download with the other 1.8.5 downloads. [Less]